madwifi 0.9.2 and CentOS 4.4 Upgrade

august 23, 2006

The CentOS team has released the upgrade RPMs to bring a CentOS 4.3 system up-to-date with what will be CentOS 4.4 (aka. Red Hat Enterprise Linux 4 Update 4). Anyways, the new update includes a kernel upgrade. The kernel version is now 2.6.9-42.0.2.EL. Unfortunately, ATrpms does not have a madwifi package for this kernel version yet, so I did not have any support for my D-Link DWL-G630 card (Atheros). But, all is not lost. Being a cowboy, I went to go build the driver myself. Easy, I thought, especially with such easy instructions from the madwifi team (basically: download, gunzip, untar, "make" then "make install"). Of course, with my luck, things aren't easy...ever. I ran into this error when I tried a "make":

/madwifi-0.9.2/net80211/ieee80211_wireless.c:4949: error: unknown field `get_wireless_stats' specified in initializer
Sigh. Anyways, it's not hard to get around, so I wanted to document this for myself. Peruse if you have the same problem. Just open up that file (net80211/ieee80211_wireless.c) and remove:
#if WIRELESS_EXT >= 17 .get_wireless_stats = ieee80211_iw_getstats, #endif
Then do another "make" and it should be good to go. Yea, the fix was easy. Update:  So, uh, around 30 minutes AFTER I figure out how to get madwifi installed, I took one last peek at ATrpms...And I found that they had built the driver just shortly after I did and packaged an RPM.  So, if you're looking to get your Atheros-based wifi card working, there is a RPM package for the 2.6.9.42.0.2.EL kernel available at ATrpms.  Sigh.  Never...ever...easy.